Re: F150 4.6 saga continues

[ Follow Ups ] [ Post Followup ] [ Off Topics Forum ] [ FAQ ]

Posted by Dave2N on January 20, 2019 at 12:15:07 [URL] [DELETE] :

In Reply to: Re: F150 4.6 saga continues posted by lonestarjeff on January 19, 2019 at 13:26:13:

If you don’t have O2 sensor codes I wouldn’t replace them. Especially since the Chinese replacements are are hit and miss. Can you check you fuel trims with scanner? Did you remove the oil pan? Was there anything interesting in it. Does it start up, with no delay? Ex. Extended crank. Have you done a compression test on motor? It sounds like a crankshaft or camshaft position sensor. But it should be blowing some codes. Anyway you miss connected cam sensor? 4.6 are great motors. You timing looks balls on. Anything in intake system. Like a mouse nest? Seen them build a condo in a air box.


Follow Ups:


Post a Followup:
Name   : 
E-Mail : 
Subject: 
Message: To add a single image to your post, click here. To add multiple images to your post, click here. Optional Link URL : http://www.yourwebsite.com Link Title : Website Title Optional Image URL: http://www.myimages.com/mypic.jpg
Enter image characters into the text box.

Press Preview Message button below to proofread message & check if images and/or links are shown before posting message. Press
browser's back button if correction is needed. Press Post Message button on Preview Message page to finalized your post. Thanks!
  
   

[ Follow Ups ] [ Post Followup ] [ Off Topics Forum ] [ FAQ ]