Re: 8N losing oil prime

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]

Posted by TheOldHokie on July 23, 2020 at 06:47:41 [URL] [DELETE] :

In Reply to: Re: 8N losing oil prime posted by Greg on July 23, 2020 at 05:40:33:

If it isn't working I don't see any way around taking it apart again. Within the last year (or there about) Just8N's was selling the same defective oil pump kits (Atlantic Quality Parts)as everyone else. The kits were cheaper than Tisco/Sparex/A&I and many of the retailers were distributing them. I spent a while on the telephone with Derrick getting a resolution for the four I purchased from them. Quite possible the machine shop is sourcing their own parts or had an Atlantic kit they got from Just8N's on the shelf. I just ordered two kits from Just8N's and I will be checking them the minute they show up. A couple weeks ago I got a pump to rebuild and the guy supplied his own parts. You guessed it - junk gears. No guarantee your problem is the gears but....

TOH


Follow Ups:


Post a Followup:
Name   : 
E-Mail : 
Subject: 
Message: To add a single image to your post, click here. To add multiple images to your post, click here. Optional Link URL : http://www.yourwebsite.com Link Title : Website Title Optional Image URL: http://www.myimages.com/mypic.jpg
Enter image characters into the text box.

Press Preview Message button below to proofread message & check if images and/or links are shown before posting message. Press
browser's back button if correction is needed. Press Post Message button on Preview Message page to finalized your post. Thanks!
  
   

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]