weak spark at plugs

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]

Posted by Greg on June 12, 2020 at 08:58:58 [URL] [DELETE] :

Sorry this is a long one. 52 8n side mount distributor. Has been running rough lately. It runs fine after a few minutes would act like it is choking up and stalls. Will start after a little while and seems to run ok. Kept getting worse. I did find a blown head gasket. Pulled head had it surfaced and reassembled. It ran much better but was still having the symptoms mentioned above. I had a 12 volt conversion kit for years so put it on thinking it might help having all new harness. It seems to be worse now. I put new points condensor distributor cap and rotor copper core wires and plugs. I seem to get good spark at points but weak at the plugs. I even tried other coils I had around. Good fuel flow. I even put another carb I had still acts the same. I need help desperatly. Any suggestions.


Follow Ups:


Post a Followup:
Name   : 
E-Mail : 
Subject: 
Message: To add a single image to your post, click here. To add multiple images to your post, click here. Optional Link URL : http://www.yourwebsite.com Link Title : Website Title Optional Image URL: http://www.myimages.com/mypic.jpg
Enter image characters into the text box.

Press Preview Message button below to proofread message & check if images and/or links are shown before posting message. Press
browser's back button if correction is needed. Press Post Message button on Preview Message page to finalized your post. Thanks!
  
   

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]