Re: Ford 660 loader hydraulic hose connections

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]

Posted by TheOldHokie on November 07, 2019 at 12:18:36 [URL] [DELETE] :

In Reply to: Ford 660 loader hydraulic hose connections posted by Gary Budd on November 05, 2019 at 09:11:15:

Your loader has two single acting lift cylinders and two double acting bucket cylinders. It is also equipped with a valve with two double acting spools which requires some thought on the plumbing. The side ports on the valve are the IN and OUT ports for the pump and reservoir but I can't tell which is which from the pictures. I would expect the body to be stamped with some sort of legend indicating which is which. There is no indication of a front pump on the loader frame so I am guessing it was using the tractor hydraulics under the seat for the loader? If so send me a picture of that area.

Before I go any further have you checked the valve and cylinders to see if there was any fire damage to the seals? Its pretty clear they got very hot.

TOH



Follow Ups:


Post a Followup:
Name   : 
E-Mail : 
Subject: 
Message: To add a single image to your post, click here. To add multiple images to your post, click here. Optional Link URL : http://www.yourwebsite.com Link Title : Website Title Optional Image URL: http://www.myimages.com/mypic.jpg
Enter image characters into the text box.

Press Preview Message button below to proofread message & check if images and/or links are shown before posting message. Press
browser's back button if correction is needed. Press Post Message button on Preview Message page to finalized your post. Thanks!
  
   

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]