Re: Sporadic Rad coolant leak

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]

Posted by Kevin Fisher on August 27, 2019 at 11:43:33 [URL] [DELETE] :

In Reply to: Re: Sporadic Rad coolant leak posted by Beth and Allen on August 20, 2019 at 19:30:14:

Hello folks: Sorry for the late reply.

It's been over a week and despite my best attempts to locate even so much as a small drip has failed...no leak, and that's with the tractor running and in use, or sitting idle. And I can't see petcock drain plug either, unless I'm really looking in the wrong place.

I am using a 50/50 ratio for the coolant. As for the hose age...well i wouldn't say they are -new- but they're not showing any obvious signs of cracking. I've checked the clamps as well and they appear to be quite tight. We've gone from warm weather to rather cold weather in a short time so I would have expected to see an expansion/contraction leak.

Of course everything would be a lot easier if I could see even a drip hanging off the bottom of something underneath the tractor...


Follow Ups:


Post a Followup:
Name   : 
E-Mail : 
Subject: 
Message: To add a single image to your post, click here. To add multiple images to your post, click here. Optional Link URL : http://www.yourwebsite.com Link Title : Website Title Optional Image URL: http://www.myimages.com/mypic.jpg
Enter image characters into the text box.

Press Preview Message button below to proofread message & check if images and/or links are shown before posting message. Press
browser's back button if correction is needed. Press Post Message button on Preview Message page to finalized your post. Thanks!
  
   

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]