hard start with new carb

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]

Posted by Ken Arms on August 11, 2019 at 13:17:13 [URL] [DELETE] :

High folks, I need some help, I have a 53 NAA, it is rebuilt. I bought a zenith style carb for it when the rebuild was fresh and it started and ran great for the last 6 years or so, the zenith started giving trouble, leaking and engine rough running after the tractor was hot. I rebuilt it with a kit but same issues. I finally decided to replace it with a new carb. got the carb off amazon, its a copy of the Marvel Shibler (bad spelling) that was on it originally. Now the NAA runs great but starts very hard. With the zenith it would start by one or two cranks (12volt conversion). Now it cranks and cranks. choke seems to make it worse. I have tried adjusting gas and air but I cant seem to find a good setting. Help?? Ken


Follow Ups:


Post a Followup:
Name   : 
E-Mail : 
Subject: 
Message: To add a single image to your post, click here. To add multiple images to your post, click here. Optional Link URL : http://www.yourwebsite.com Link Title : Website Title Optional Image URL: http://www.myimages.com/mypic.jpg
Enter image characters into the text box.

Press Preview Message button below to proofread message & check if images and/or links are shown before posting message. Press
browser's back button if correction is needed. Press Post Message button on Preview Message page to finalized your post. Thanks!
  
   

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]