New 641 electrical problem

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]

Posted by Mike in Michigan on April 12, 2019 at 15:55:43 [URL] [DELETE] :

I have had some issues with my 641 and the starter switch, often having to do the screwdriver to ground bypass. I have replaced the starter switch a couple of times already.
This time I was just getting a little spark when trying the screwdriver bypass. I put the battery on a charger and then she started up right away (no screwdriver needed). And she ran real good thereafter.

However I did notice a couple of odd things.
1. The charging light on the tractor was really bright and stayed on the whole time the tractor was running. Typically the light will have a mid-glow when turning the ignition and go off shortly after running.
2. The fuel gas gauge no longer works (the oil pressure gauge works). Happened at the same time as #1 as far as I noticed.

The tractor had not been started for a couple of months prior to this. I was wondering if my bypass technique caused something else to short out.


Follow Ups:


Post a Followup:
Name   : 
E-Mail : 
Subject: 
Message: To add a single image to your post, click here. To add multiple images to your post, click here. Optional Link URL : http://www.yourwebsite.com Link Title : Website Title Optional Image URL: http://www.myimages.com/mypic.jpg
Enter image characters into the text box.

Press Preview Message button below to proofread message & check if images and/or links are shown before posting message. Press
browser's back button if correction is needed. Press Post Message button on Preview Message page to finalized your post. Thanks!
  
   

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]