8n ring seating

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]

Posted by Michael on October 20, 2018 at 14:57:28 [URL] [DELETE] :


I have a 1951 8n that has a rebuilt engine. New pistons, rings, sleeves, valves ( valves were lapped) , bearings, etc. the problem is I have low compression (~85 per each cylinder). And the engine runs a little rough. Will hesitate on take off. I have checked all the electrical (at least to my knowledge) and can find no reason for the rough running except the low compression maybe. I have spark to all plugs. Timing is correct. Can mark is lined up with crank mark. Wires, coil etc are good. It does not burn oil and I see no smoke from tailpipe and no exhaust gases from oil breather. I'm at my wits end. Could it be that the rings are not seating ?? What could I do to get them to seat if this is possibly the problem. Thanks


Follow Ups:


Post a Followup:
Name   : 
E-Mail : 
Subject: 
Message: To add a single image to your post, click here. To add multiple images to your post, click here. Optional Link URL : http://www.yourwebsite.com Link Title : Website Title Optional Image URL: http://www.myimages.com/mypic.jpg
Enter image characters into the text box.

Press Preview Message button below to proofread message & check if images and/or links are shown before posting message. Press
browser's back button if correction is needed. Press Post Message button on Preview Message page to finalized your post. Thanks!
  
   

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]