1953 Jubilee Electrical Problem

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]

Posted by Chuck on September 17, 2018 at 11:17:29 [URL] [DELETE] :

I have a 1953 Jubilee that is burning points. I put a fresh set of points in and get about 4 hours of use and the points burn out and need to be replaced. We checked the voltage at the battery, before and after the coil and at the distributor while the tractor is running and the voltage tends to run extremely high where it is unreadable. Any ideas on what to look for???? The only thing we haven't done is replace the voltage regulator which is next on the agenda in hopes that that is the problem. When I look at the install directions, it states that I need to 'polarize' the generator. Why or what is the reason for doing this? Thanks for any advice and/or help as this is frustrating the heck out of me. Thanks


Follow Ups:


Post a Followup:
Name   : 
E-Mail : 
Subject: 
Message: To add a single image to your post, click here. To add multiple images to your post, click here. Optional Link URL : http://www.yourwebsite.com Link Title : Website Title Optional Image URL: http://www.myimages.com/mypic.jpg
Enter image characters into the text box.

Press Preview Message button below to proofread message & check if images and/or links are shown before posting message. Press
browser's back button if correction is needed. Press Post Message button on Preview Message page to finalized your post. Thanks!
  
   

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]