Re: 8n power loss when using bush hog

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]

Posted by Dead Eye Dave on August 23, 2018 at 13:14:39 [URL] [DELETE] :

In Reply to: 8n power loss when using bush hog posted by Denise on August 23, 2018 at 11:00:47:

Well, Denise, I am not a mechanic either but I will suggest a couple of things. I would check the bush hog gear box to make sure it was full of lubricant. I would then look under the bush hog deck to see if there was anything tangled in there. Sometimes it can pick up wire or rope. If all of this is OK then I might check fuel flow. If the screens get clogged up then when you put demand on the tractor the engine does not get enough. It may get enough to operate without load or at idle but not when working. The last but not least is if it is heating up when working. Is the radiator topped up? Just needs to be at the top of the fins when looking in the filler. Nothing else comes to my mind. Good luck. Dave


Follow Ups:


Post a Followup:
Name   : 
E-Mail : 
Subject: 
Message: To add a single image to your post, click here. To add multiple images to your post, click here. Optional Link URL : http://www.yourwebsite.com Link Title : Website Title Optional Image URL: http://www.myimages.com/mypic.jpg
Enter image characters into the text box.

Press Preview Message button below to proofread message & check if images and/or links are shown before posting message. Press
browser's back button if correction is needed. Press Post Message button on Preview Message page to finalized your post. Thanks!
  
   

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]