naa hydraulics

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]

Posted by Doug on March 10, 2018 at 21:52:03 [URL] [DELETE] :

On my naa we just did hubs and what not on we tackled the hydraulics that have always dropped on me. We changed the piston, new o ring and wiper. We put in a new hydraulic safety valve assembly. We did remove the pump from the top plate to clean it up but did not mess with any of the position arm or draft linkage. Wilkes all the reservoirs with oil today and fired her up. After realizing it was in draft mode we began to bleed any air from the system that we could. Once it started to work as it should and all the air was gone it still drops then jumps right back up. Quicker than before but is still doing the same thing s before. We pulled the fill plug and can not see any oil getting by the oring and or wiper on the new piston and it doesn't look like anything is coming from the safety valve assembly.please help I am at a loss. Thank you.

Follow Ups:

Post a Followup:
Name   : 
E-Mail : 
Message: To add a single image to your post, click here. To add multiple images to your post, click here. Optional Link URL : Link Title : Website Title Optional Image URL:
Enter image characters into the text box.

Press Preview Message button below to proofread message & check if images and/or links are shown before posting message. Press
browser's back button if correction is needed. Press Post Message button on Preview Message page to finalized your post. Thanks!

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]