3 pt lift response

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]

Posted by BrianS, NE on November 27, 2017 at 19:32:57 [URL] [DELETE] :

OK. So I have been fighting this for a while. I realize the best solution may have been to tear the pump apart and start fresh, but didn't get it done.

Background. 8N, lifts strong, not much leak down.

Issue is very slow dropping when I want it down. Last year, I dropped the pump, cleaned really well including a bath in diesel. I also replaced the exhaust valve spring after consultations with folks here.

Put it all back together, and nothing changed. I ran out of time and had to get ready for winter and suffered through it.

I have a second 8N which had no issues. My thought was to just swap the pump into my worker and then work on the removed pump as time permitted.

As you can guess, the pump from #2 put into #1, the worker that had the issue, is exhibiting the same slow drop.

My question is, is there somewhere else in the "plumbing" that could be causing the slow response to drop the implement?

Am I making an sense?

Thanks guys.....


Follow Ups:


Post a Followup:
Name   : 
E-Mail : 
Subject: 
Message: To add a single image to your post, click here. To add multiple images to your post, click here. Optional Link URL : http://www.yourwebsite.com Link Title : Website Title Optional Image URL: http://www.myimages.com/mypic.jpg
Enter image characters into the text box.

Press Preview Message button below to proofread message & check if images and/or links are shown before posting message. Press
browser's back button if correction is needed. Press Post Message button on Preview Message page to finalized your post. Thanks!
  
   

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]