Hydraulic Lift,,,again !

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]

Posted by Charles(N.C.) on May 11, 2017 at 13:19:18 [URL] [DELETE] :

Sometime back (I've been under the weather)I posted about my lift and what I was doing.I've pulled the top cover for repairs and removed the bottom pump.The pump had a stuck intake valve and the pressure relief was exchanged.The top I honed the lift cylinder smooth and replaced the lift pin.Used a new type cylinder piston and gasket.New hyd.fluid now NO LIFT !The fluid is moving in the pump with no aggitation and I see,feel no lift cylinder leaks.Now if I lift the arms by hand they will hold and when I cut the engine off the arms still hold ((how long ?)but the arms,pump will not lift.For the life of me I can only surmise the pump is not pumping fluid to the hydraulics.I'm still on some "under the weather meds" and one has just kicked in so I'm hoping I make scence.Help !Thanks!


Follow Ups:


Post a Followup:
Name   : 
E-Mail : 
Subject: 
Message: To add a single image to your post, click here. To add multiple images to your post, click here. Optional Link URL : http://www.yourwebsite.com Link Title : Website Title Optional Image URL: http://www.myimages.com/mypic.jpg
Enter image characters into the text box.

Press Preview Message button below to proofread message & check if images and/or links are shown before posting message. Press
browser's back button if correction is needed. Press Post Message button on Preview Message page to finalized your post. Thanks!
  
   

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]