Re: Hydraulic fluid mistake

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]

Posted by Kevin on April 24, 2017 at 10:54:00 [URL] [DELETE] :

In Reply to: Hydraulic fluid mistake posted by Kevin on April 22, 2017 at 19:56:42:


So I drained the gear oil and put in UTF. Lift arms (nothing attached) do not move. Draft lever is vertical. Tried at idle and about 900 RPM.

I pressurized the hydraulic sump with about 40 PSI shop air through the dip-stick hole. It's sealed up enough that it does pressurize and when I remove the nozzel I get a fair amount of air pushing out of the sump. I tried that for a while but didn't get any obvious effects.

I eventually got the plug out of the pump. Looked in and saw some oil slowly receding---looked fairly thick, more like gear oil than UTF. Then I pressurized the sump with the plug out and saw oil filling into the pump body. Should I keep going and flush this out a bit? At the time, I decided that I wouldn't add to the mess on the garage floor but now that I'm writing this, I see that it might be the right thing to do.

Thanks for the help so far!


Follow Ups:


Post a Followup:
Name   : 
E-Mail : 
Subject: 
Message: To add a single image to your post, click here. To add multiple images to your post, click here. Optional Link URL : http://www.yourwebsite.com Link Title : Website Title Optional Image URL: http://www.myimages.com/mypic.jpg
Enter image characters into the text box.

Press Preview Message button below to proofread message & check if images and/or links are shown before posting message. Press
browser's back button if correction is needed. Press Post Message button on Preview Message page to finalized your post. Thanks!
  
   

[ Follow Ups ] [ Post Followup ] [ N Board Forum ] [ FAQ ]