Davis 100 Loader Hydraulic filter Issue.

[ Follow Ups ] [ Post Followup ] [ Implements Forum ] [ FAQ ]

Posted by Roger House on June 15, 2015 at 12:45:41 [URL] [DELETE] :

I have a 1954 Ford NAA with a davis 100 loader. Recently had issues with a broken bolt on vickers pump so had to remove all Hyd.. from front of tractor to fix. upon cleaning, painting etc I went to get a new Hydraulic filter (Original M-F part #1752177m1) at NAPA. well they no longer make , but they were kind enought to tell me that a Local baldwin filter dealer had the replacement(P40). Here is my problem/question; in cleaning the filter tank assembly I see that there are four larger holes in a larger shoulder in the back of the tank beyond the old sock filter mount tube and the new paper filter. Logic tells me the pump will suck unfiltered oil throught those hole before sucking through filter. It would seem that the/a filter to do its job should cover those holes too. Is there a better filter to use and How does one find a replacement screen. Great web site. Thanks for any help.


Follow Ups:


Post a Followup:
Name   : 
E-Mail : 
Subject: 
Message: To add a single image to your post, click here. To add multiple images to your post, click here. Optional Link URL : http://www.yourwebsite.com Link Title : Website Title Optional Image URL: http://www.myimages.com/mypic.jpg
Enter image characters into the text box.

Press Preview Message button below to proofread message & check if images and/or links are shown before posting message. Press
browser's back button if correction is needed. Press Post Message button on Preview Message page to finalized your post. Thanks!
  
   

[ Follow Ups ] [ Post Followup ] [ Implements Forum ] [ FAQ ]