Re: jubilee pto won't engage

[ Follow Ups ] [ Post Followup ] [ Ads Forum ] [ FAQ ]

Posted by Tim Daley(MI) on April 30, 2019 at 04:42:50 [URL] [DELETE] :

In Reply to: jubilee pto won't engage posted by jim mindy on April 29, 2019 at 17:02:02:

You posted on our ADS forum. Move it over to the regular N-BOARD. Also, if you don't have the manuals, get them. You need to know how to correctly and safely operate your machine. Did you engage the clutch? Clutch mist be engaged first. Then advance the PTO lever to engage it? Why are you using a pipe wrench??? That's like giving a monkey a hand grenade. The PTO cover has nothing to do with the function of the PTO shaft. It is only there as a safety feature; to protect the operator from getting clothing caught in it wen spinning. Take some PB BLASTER and spray around the cap threads several times day for a few days then try to loosen it.

Tim Daley(MI)


Follow Ups:


Post a Followup:
Name   : 
E-Mail : 
Subject: 
Message: To add a single image to your post, click here. To add multiple images to your post, click here. Optional Link URL : http://www.yourwebsite.com Link Title : Website Title Optional Image URL: http://www.myimages.com/mypic.jpg
Enter image characters into the text box.

Press Preview Message button below to proofread message & check if images and/or links are shown before posting message. Press
browser's back button if correction is needed. Press Post Message button on Preview Message page to finalized your post. Thanks!
  
   

[ Follow Ups ] [ Post Followup ] [ Ads Forum ] [ FAQ ]