jubilee pto won't engage

[ Follow Ups ] [ Post Followup ] [ Ads Forum ] [ FAQ ]

Posted by jim mindy on April 29, 2019 at 17:02:02 [URL] [DELETE] :

Good Afternoon All: Problem with PTO, won't engage. New tractor to me, the cap was rusted on so I didn't get a look at it when buying, just assumed it worked. You know what they say about assuming? Anyway, too late to complain. The shaft turns by hand now but needed help with a pipe wrench to get it to move. The engagement handle is slightly bent backwards indicating that someone tried real hard to make it engage. If you press hard on the handle you can feel very slightly a spline rotating but the handle appears to be in the rear, engaged position. You cannot move the handle forward.
Any suggestions as to the cure?

5224


Follow Ups:


Post a Followup:
Name   : 
E-Mail : 
Subject: 
Message: To add a single image to your post, click here. To add multiple images to your post, click here. Optional Link URL : http://www.yourwebsite.com Link Title : Website Title Optional Image URL: http://www.myimages.com/mypic.jpg
Enter image characters into the text box.

Press Preview Message button below to proofread message & check if images and/or links are shown before posting message. Press
browser's back button if correction is needed. Press Post Message button on Preview Message page to finalized your post. Thanks!
  
   

[ Follow Ups ] [ Post Followup ] [ Ads Forum ] [ FAQ ]